Outlook Client in Citrix 4.0 Umgebung

Hallo zusammen.

Wir haben den CRM 3.0 Outlook Client in einer Citrix Umgebung installiert. Nachdem die Citrix-Anmeldung erfolgt ist kann auch mittels Outlook auf den CRM Server zugegriffen werden, mit einer Einschränkung :
Wenn für eine Entität in der ISV Config z.B. ein zusätzlicher Button deklariert wurde, wird dieser nicht angezeigt. Die Benutzer müssen zuerst die Entität schließen, über die Einstellungen im Internet Explorer alle Cookies löschen und die Entität erneut öffnen. Danach funktionieren auch alle zusätzlichen Definitionen in aus der ISV Config.
Leider reichen hier meine Citrix Kenntnisse nicht aus.
Hat jemand eine Idee, wo hier der Fehler zu suchen ist ?

Details zur Systemumgebung gebe ich gerne, würde aber erstmal den Rahmen sprengen.


AW: Outlook Client in Citrix 4.0 Umgebung

Hallo,

ich würde hier nicht von einem Fehler sprechen, sondern eher mal auf das Phänomen der "Roaming-Profiles" tippen. Denn auch die Einstellungen des IE werden für jeden User in einer Citrix-Session individuell gespeichert.

Gruß


AW: Outlook Client in Citrix 4.0 Umgebung

Hallo Jörg,
ich kann dir leider auch nicht sagen woran es liegt.

ich habe aber eine andere Frage an dich.
unsere Admins haben Outlook Client auch in Citrix 4.0 installiert.
Allerdings nicht so wie in MS beschrieben ist, sondern haben alle Dateien und Registiries ausgepackt und es manuell gemacht. ich habe aber Problem, wenn man auf "Synchrinization Outlook to CRM" Button drückt kommt Fehler und kann es die Synchrinization nicht beenden.

habt ihr Installation so durchgeführt wie es in MS beschrieben ist? mit dieser Batch Datei, die für jeder User ausgeführt werden muss? habt ihr Rollup Update 3 auch installiert, hatte andere Auswirkungen?

Danke im Voraus
Cagatay


AW: Outlook Client in Citrix 4.0 Umgebung

>>> Hallo zusammen.
>>>
>>> Wir haben den CRM 3.0 Outlook Client in einer Citri
>>> x Umgebung installiert. Nachdem die Citrix-Anmeldung erfolgt ist kann auch mitte
>>> ls Outlook auf den CRM Server zugegriffen werden, mit einer Einschränkung :
>>>
>>> Wenn für eine Entität in der ISV Config z.B. ein zusätzlicher Button deklarier
>>> t wurde, wird dieser nicht angezeigt. Die Benutzer müssen zuerst die Entität sch
>>> ließen, über die Einstellungen im Internet Explorer alle Cookies löschen und die
>>> Entität erneut öffnen. Danach funktionieren auch alle zusätzlichen Definitione
>>> n in aus der ISV Config.
>>> Leider reichen hier meine Citrix Kenntnisse nich
>>> t aus.
>>> Hat jemand eine Idee, wo hier der Fehler zu suchen ist ?

Hi,

auch wenns sehr spät kommt, vielleicht lebt ihr ja noch mit dem Problem oder andere Leute suchen vielleicht nach einer Lösung für das gleiche Problem.
Wir hatten das selbe Phänomen bei einem unserer Kunden mit bekommen, die von einem anderen Systemhaus gesagt bekommen hatten, dies wäre der einzige Work-Around. Dabei war das Problem recht einfach...

In den System-Settings kann eingestellt werden, ob die ISV-Erweiterungen im Web- oder Outlook-Client oder beiden sichtbar seien sollen. Hier muss natürlich auch beides aktiviert sein.
Zusätzlich kann in der isv.config für jeden Button einzeln definiert werden, ob der Button wiederum nur in einem der Clients oder in beiden auftauchen soll. Wenn bei dem Button irgendwo Client="Web" steht, dann dieses Attribut einfach entfernen.

CRM legt beim Start von Outlook einen Cookie an, in dem steht, dass es sich um den Web-Client handelt. CRM verarbeitet diese Info später bei jedem Seitenaufruf und zeigt - bei falschen Settings in der isv - dann eben keine Buttons mehr an. Durch das manuelle Löschen der Cookies, weiss das CRM dann nicht mehr, dass der Aufruf durch Outlook kam und denkt es handelt sich um den Web-Client. Entsprechend werden die Buttons dann angezeigt...

Hoffe irgendwer liest den Beitrag irgendwann noch und kann das Problem damit beheben ;)

Gruß
Thomas